Home > OSPF Default-information originate and ABR

OSPF Default-information originate and ABR

April 4th, 2025 Go to comments

The purpose of this lab is to test if the default route generated by the “default-information originate” on R1 can be sent to the stub area (R4 & R5).

Topology

topo.jpg

Note:
+ Each router Rn has one loopback interface n.n.n.n/32. R3 has two loopback interfaces: Lo0 in Area 0 and Lo1 in Area 1
+ The last octet of the IP address of each router is the same as the router number

Initial configs

R1

hostname R1
!
interface e0/0
 ip address 10.1.1.1 255.255.255.0
 no shut
interface e0/1
 ip address 10.10.10.1 255.255.255.252
 no shut
interface lo0
 ip address 1.1.1.1 255.255.255.255
!
ip route 0.0.0.0 0.0.0.0 10.10.10.2
!
router ospf 1
 network 10.1.1.1 0.0.0.0 area 0
 network 1.1.1.1 0.0.0.0 area 0

R2

hostname R2
!
interface e0/0
 ip address 10.1.1.2 255.255.255.0
 no shut
interface lo0
 ip address 2.2.2.2 255.255.255.255
!
router ospf 1
 network 10.1.1.2 0.0.0.0 area 0
 network 2.2.2.2 0.0.0.0 area 0

R3

hostname R3
!
interface e0/0
 ip address 10.1.1.3 255.255.255.0
 no shut
interface e0/1
 ip address 10.1.2.3 255.255.255.0
 no shut
interface lo0
 ip address 3.3.3.3 255.255.255.255
interface lo1
 ip address 33.33.33.33 255.255.255.255
!
router ospf 1
 network 10.1.1.3 0.0.0.0 area 0
 network 3.3.3.3 0.0.0.0 area 0
 network 10.1.2.3 0.0.0.0 area 1
 network 33.33.33.33 0.0.0.0 area 1

R4

hostname R4
!
interface e0/0
 ip address 10.1.2.4 255.255.255.0
 no shut
interface lo0
 ip address 4.4.4.4 255.255.255.255
!
router ospf 1
 network 10.1.2.4 0.0.0.0 area 1
 network 4.4.4.4 0.0.0.0 area 1

R5

hostname R5
!
interface e0/0
 ip address 10.1.2.5 255.255.255.0
 no shut
interface lo0
 ip address 5.5.5.5 255.255.255.255
!
router ospf 1
 network 10.1.2.5 0.0.0.0 area 1
 network 5.5.5.5 0.0.0.0 area 1

ISP

hostname ISP
!
interface e0/0
 ip address 10.10.10.2 255.255.255.252
 no shut
!
ip route 0.0.0.0 0.0.0.0 10.10.10.1

Everything works correctly and R3 (ABR) can see everyone:

R3#sh ip route ospf
--output omitted--

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/11] via 10.1.1.1, 00:11:43, Ethernet0/0
      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/11] via 10.1.1.2, 00:11:33, Ethernet0/0
      4.0.0.0/32 is subnetted, 1 subnets
O        4.4.4.4 [110/11] via 10.1.2.4, 00:11:00, Ethernet0/1
      5.0.0.0/32 is subnetted, 1 subnets
O        5.5.5.5 [110/11] via 10.1.2.5, 00:10:50, Ethernet0/1

Configure Stub area

First we will configure Area 1 stub area. On R3, R4 and R5 we use the same commands:

On R3, R4, R5:
router ospf 1
 area 1 stub

R3 now generates a default route and advertise to R4 & R5:

R4#sh ip route ospf
--output omitted--

Gateway of last resort is 10.1.2.3 to network 0.0.0.0

O*IA  0.0.0.0/0 [110/11] via 10.1.2.3, 00:05:22, Ethernet0/0
      1.0.0.0/32 is subnetted, 1 subnets
O IA     1.1.1.1 [110/21] via 10.1.2.3, 00:05:32, Ethernet0/0
      2.0.0.0/32 is subnetted, 1 subnets
O IA     2.2.2.2 [110/21] via 10.1.2.3, 00:05:32, Ethernet0/0
      3.0.0.0/32 is subnetted, 1 subnets
O IA     3.3.3.3 [110/11] via 10.1.2.3, 00:05:32, Ethernet0/0
      5.0.0.0/32 is subnetted, 1 subnets
O        5.5.5.5 [110/11] via 10.1.2.5, 00:05:32, Ethernet0/0
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O IA     10.1.1.0/24 [110/20] via 10.1.2.3, 00:05:32, Ethernet0/0
      33.0.0.0/32 is subnetted, 1 subnets
O        33.33.33.33 [110/11] via 10.1.2.3, 00:05:32, Ethernet0/0

This is a Type 3 LSA (Summary Net Link States):

R4#show ip ospf database

            OSPF Router with ID (10.1.2.4) (Process ID 1)

                Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
10.1.2.3        10.1.2.3        191         0x8000000C 0x0093B4 2
10.1.2.4        10.1.2.4        193         0x8000000B 0x00BEFC 2
10.1.2.5        10.1.2.5        378         0x80000009 0x00EEC7 2

                Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
10.1.2.5        10.1.2.5        373         0x80000007 0x00B624

                Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
0.0.0.0         10.1.2.3        389         0x80000001 0x002FFE
1.1.1.1         10.1.2.3        389         0x80000002 0x0063BB
2.2.2.2         10.1.2.3        389         0x80000002 0x0035E5
3.3.3.3         10.1.2.3        389         0x80000002 0x00A27E
10.1.1.0        10.1.2.3        389         0x80000003 0x00EB2B

With this default route, R4 can ping R1 loopback0 (1.1.1.1):

R4#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!

Turn on “default-information originate” command

Now let’s see what will happen when we use the “default-information originate” command on R1 to advertise a default route to its downstream routers:

R1:
router ospf 1
 default-information originate

Let’s check the OSPF topology on R3:

R3#sh ip ospf database

            OSPF Router with ID (10.1.2.3) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
10.1.1.1        10.1.1.1        134         0x80000009 0x00DDF6 2
10.1.1.2        10.1.1.2        1806        0x80000008 0x0006CA 2
10.1.2.3        10.1.2.3        1787        0x80000007 0x0025A2 2

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
10.1.1.3        10.1.2.3        1048        0x80000006 0x005393

                Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
4.4.4.4         10.1.2.3        40          0x80000002 0x00BA56
5.5.5.5         10.1.2.3        1014        0x80000001 0x008E7F
10.1.2.0        10.1.2.3        1787        0x80000004 0x00C052
33.33.33.33     10.1.2.3        40          0x80000002 0x001B8B

                Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
10.1.2.3        10.1.2.3        835         0x8000000C 0x0093B4 2
10.1.2.4        10.1.2.4        839         0x8000000B 0x00BEFC 2
10.1.2.5        10.1.2.5        1023        0x80000009 0x00EEC7 2

                Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
10.1.2.5        10.1.2.5        1018        0x80000007 0x00B624

                Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
0.0.0.0         10.1.2.3        1034        0x80000001 0x002FFE
1.1.1.1         10.1.2.3        1034        0x80000002 0x0063BB
2.2.2.2         10.1.2.3        1034        0x80000002 0x0035E5
3.3.3.3         10.1.2.3        1034        0x80000002 0x00A27E
10.1.1.0        10.1.2.3        1034        0x80000003 0x00EB2B

                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
0.0.0.0         10.1.1.1        135         0x80000001 0x00CBD9 1

We see R3 received a Type 5 LSA from R1, which is the default route generated via the “default-information originate” command above.

The routing table of R3 now has this default route:

R3#sh ip route ospf
--output omitted--

Gateway of last resort is 10.1.1.1 to network 0.0.0.0

O*E2  0.0.0.0/0 [110/1] via 10.1.1.1, 00:03:41, Ethernet0/0
      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/11] via 10.1.1.1, 00:18:47, Ethernet0/0
      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/11] via 10.1.1.2, 00:18:47, Ethernet0/0
      4.0.0.0/32 is subnetted, 1 subnets
O        4.4.4.4 [110/11] via 10.1.2.4, 00:18:47, Ethernet0/1
      5.0.0.0/32 is subnetted, 1 subnets
O        5.5.5.5 [110/11] via 10.1.2.5, 00:18:27, Ethernet0/1

How about R4 & R5? Let’s check its OSPF database:

R4#sh ip ospf database

            OSPF Router with ID (10.1.2.4) (Process ID 1)

                Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
10.1.2.3        10.1.2.3        1112        0x8000000C 0x0093B4 2
10.1.2.4        10.1.2.4        1114        0x8000000B 0x00BEFC 2
10.1.2.5        10.1.2.5        1299        0x80000009 0x00EEC7 2

                Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
10.1.2.5        10.1.2.5        1294        0x80000007 0x00B624

                Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
0.0.0.0         10.1.2.3        1311        0x80000001 0x002FFE
1.1.1.1         10.1.2.3        1311        0x80000002 0x0063BB
2.2.2.2         10.1.2.3        1311        0x80000002 0x0035E5
3.3.3.3         10.1.2.3        1311        0x80000002 0x00A27E
10.1.1.0        10.1.2.3        1311        0x80000003 0x00EB2B

We can see the Type 5 LSA has been blocked from entering stub area so the OSPF database of R4 remains unchanged.

The routing table of R4 remains unchanged:

R4#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is 10.1.2.3 to network 0.0.0.0

O*IA  0.0.0.0/0 [110/11] via 10.1.2.3, 00:32:51, Ethernet0/0
      1.0.0.0/32 is subnetted, 1 subnets
O IA     1.1.1.1 [110/21] via 10.1.2.3, 00:33:01, Ethernet0/0
      2.0.0.0/32 is subnetted, 1 subnets
O IA     2.2.2.2 [110/21] via 10.1.2.3, 00:33:01, Ethernet0/0
      3.0.0.0/32 is subnetted, 1 subnets
O IA     3.3.3.3 [110/11] via 10.1.2.3, 00:33:01, Ethernet0/0
      5.0.0.0/32 is subnetted, 1 subnets
O        5.5.5.5 [110/11] via 10.1.2.5, 00:33:01, Ethernet0/0
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O IA     10.1.1.0/24 [110/20] via 10.1.2.3, 00:33:01, Ethernet0/0
      33.0.0.0/32 is subnetted, 1 subnets
O        33.33.33.33 [110/11] via 10.1.2.3, 00:33:01, Ethernet0/0

Summary

The default route generated and forwarded via the “default-information originate” command is a Type 5 LSA and it is blocked by the ABR of the Stub area. In the table below, it is shown by “Type 5 LSA” column and “Stub Area” row:

OSPF_LSAs_Area_types.jpg

 

Comments (0) Comments
  1. No comments yet.